Problème réceptivité,temporisation et HMI TIA Portal Siemens

  • KRIVORAJANIN
    KRIVORAJANIN
    Modérateur
    Automaticien amateur

    2 messages
    Inscrit le 15/09/2016

    le 20/04/2019 à 16:54 Citer ce message

    Bonjour,
    J'ai essayé de concevoir un programme qui allume 8 leds de sortie (de Q0.0 à Q0.7 sur un API 1200) avec temporisation de deux secondes. un simple grafcet en réalité avec reprise de séquence comme réceptivité une simple temporisation. Arrivé à la dernière le système reste bloqué . J"ai pu remédier à ça en insérant un RT à la sortie du dernier temporisateur pour le réinitialiser.
    Deux questions:
    1. C'est quoi cette histoire de réinitialiser un temporisateur?
    2. Dès que le système est lancé via un interrupteur comme départ cycle en principe remettre l'interrupteur OFF ne perturbe pas la marche du dispositif mais malheureusement il s’arrête.
    3. En simulant un HMI je vois dans certaines vidéos de prototype de vérins avec capteurs , de tapis etc bref où est ce qu'on télécharger de tels exemples de programmes.
  • automationsense
    automationsense
    Modérateur
    Automaticien vétéran

    483 messages
    Inscrit le 28/04/2016

    le 22/04/2019 à 17:06 Citer ce message

    Bonjour KRIVORAJANIN,

    1) Tu as besoin de réinitialiser le tempo car même si la valeur que tu as pré-réglé au niveau de ton tempo est atteinte,ton tempo reste actif.

    2) Oui n'est normal que cela s'arrête vu que ta réceptivité sera à "0"

    3) Si tu utilises WinCC,il y'a une librairie qui comporte les composants industriels dont tu auras besoin.
    Cordialement,
    Image

    " Travailles pour tes propres rêves sinon quelqu'un d'autres t'embauchera pour réaliser les siens "
  • krivorajanin
    krivorajanin

    le 23/04/2019 à 11:18 Citer ce message

    Bonjour
    Le problème c'est que en mettant l'interrupteur à 1 (départ cycle) on passe à l'étape 2 pour allumer la première LED. En principe selon les règles l'état futur d'une réceptivité qui a permis d'activer une 'étape n'aura plus d'effet sur le déroulement du grafcet (à moins que la réceptivité ne se répète).
    D'ailleurs ma question pourrait bien être tout simple: Et si à la place de l'interrupteur je plaçais un bouton poussoir?
    A vrai là aussi j'ai essayé de programmer l'interrupteur en front montant mais ça n'a pas marché.
    Remarque : Deux années successives je me suis inscris à vos cours mais malheureusement je n'ai pas eu le temps de les suivre . Est ce que les questions que je vous pose ne vous gênent pas alors que je ne fais plus partie des inscrits?
  • automationsense
    automationsense
    Modérateur
    Automaticien vétéran

    483 messages
    Inscrit le 28/04/2016

    le 23/04/2019 à 19:16 Citer ce message

    Bonjour,

    Pouvez-vous m'envoyer votre programme en version archivée.

    Remarque : Non c'est pas un problème,ici c'est un forum.
    Cordialement,
    Image

    " Travailles pour tes propres rêves sinon quelqu'un d'autres t'embauchera pour réaliser les siens "
  • krivorajanin
    krivorajanin

    le 27/04/2019 à 16:01 Citer ce message

    bonjour
    Sincèrement je ne sais comment vous envoyer un fichier archivé dans la plateforme forum.
    Cordialement
    Mahamat Ismail
  • automationsense
    automationsense
    Modérateur
    Automaticien vétéran

    483 messages
    Inscrit le 28/04/2016

    le 30/04/2019 à 20:36 Citer ce message

    Vous le mettez sur Google Drive et envoyez juste le lien.
    Cordialement,
    Image

    " Travailles pour tes propres rêves sinon quelqu'un d'autres t'embauchera pour réaliser les siens "
  • krivorajanin
    krivorajanin

    le 30/04/2019 à 21:55 Citer ce message

    bonjour
    je vous envois le lien j’espère que ça marchera.
    https://drive.google.com/file/d/133Bb39YR66k5SJTYFOkIQaJqpBnreM2z/view?usp=sharing
    Cordialement
    Mahamat Ismai
  • Charre69
    Charre69

    le 06/05/2019 à 15:39 Citer ce message

    Bonjour krivorajanin,
    je suis tombé sur de forum par hasard, ayant un peu de temps.
    j'ai vérifié ton prog, tout fonctionne. même pas besoin de reinitialiser la tempo.
    J'utilise TIA V14, mais il n'y a pas de raison.
    Par contre, quelques "règles" perso :
    _il faut éviter les set-reset pour un graph, .je prefère passer par une valeur dans un mot (pour les transitions, tu mets 0 dans le mot Grafcet pour l'étape 0, 1 pour l'étape 1 ..puis pour les étapes, tu fait une comparaison de valeur.)
    _Il faut mettre ta condition de repli (AU) dans ta première transition, si tu fait l'essai d'activer DCY sans AU, ça met l'étape 1 à 1.

    Pour ton IHM, tu as un onglet "Graphique" tout en bas de l'onglet Accessoires qui lui est tout à droite. Navigue dans cet onglet, il y a plein d'objets

Répondre à ce message

7 choses à savoir si Tu débutes en automatisme...

7 choses que tu dois savoir si tu debutes en automatismeCliquez ici pour télécharger le guide PDF

Superv 3